The Joomla! Extensions Directory ™

Viqing

Reviews(1)
 
byViqing, April 28, 2012
JoomSEF
This extension is silly-looking on the surface of it.
The extension is advertised with a name containing the word "Free".
Though in fact when going to download from the website, the options you're met with are "Purchase paid version for EUR 26.90 or TRY free version".
Secondly it's advertised as compatible with Joomla 2.5, but in fact both JoomSEF 3 and 4 are compatible only with Joomla 1.5 and 1.6.

What a laughable joke covered by a stylished website.
Owner's reply

Hi, there is nothing else to say except that what you write is a complete non-sense.
1. JoomSEF 4 does work all with Joomla 1.6, 1.7 and 2.5.
2. There really is a FREE version that works. The differences between free and paid version are well listed at our site.