The Joomla! Extensions Directory ™

jonathanperz

Reviews(1)
 
byjonathanperz, May 17, 2013
FJ Related Articles Plus
This was a must have for related content driven sites in Joomla 2.5. It needs Joomla 3.0 capability. I hope it gets developed soon.