The Joomla! Extensions Directory ™

kaufi

Reviews(1)
 
AllVideos
I use Joomla 1.0.12 and All Video 2.4!

All works fine and it's easy otherwise I couldn't start it because on a Computer I am a lefty!! :-)

Very thanks for this Mambot!!!