The Joomla! Extensions Directory ™

pdean

Reviews(1)
 
bypdean, January 15, 2012
I have used this module many times in the past and it is great. However it is not compatible with Joomla 1.7 and so should not be marked as such (above). i do hope the develop get around to upgrading it as it's a very useful module to have.