To see the number of sites that are effected by this error, google - in quotation marks - "You need Joomla! 1.7 to run this plugin!".
I used this extension for Joomla 1.7 and it worked fine. It does not work for 2.5 however, so I recommend finding another extension.
You must be kidding!?
The version for Joomla! 2.5 was already released on 25 January 2012 (almost with the release of the first stable version of Joomla! 2.5). The plugin has over 22.000 downloads (and that with only one release so far) and I had no complaints in the support forum at all.
You write this review two months after the release. You are probably not the fastest? ;-)
You have just to install the version 2.5-1 over the old files, that's all! Is it so difficult? If you are not able to do such stupid things, then you should not use my extensions or even Joomla! at all.
I don't support the version for Joomla! 1.6 and 1.7 anymore, because these Joomla! versions have some critical vulnerabilities.
I hope you will never use one of my extensions again, so I recommend you finding other extensions.
By the way: I personally had no contact with you. I don't know who you are.