The Joomla! Extensions Directory ™

webology

Reviews(1)
 
bywebology, August 21, 2013
jHackGuard
Installation: Simple
Compatibility: Both 1.5 and 2.5
and ofcourse good protection.