Introduction

jRequire is meant for developers wanting to use AMD-style JavaScript development. We encourage developers to bundle this extension with their extensions in the hope that it serves as a standard way of integrating require.js in Joomla.

  • Get this
  • Favourite
  • Report

What does it do?

After installation, you can make a simple static class method call to have an AMD module loaded and a module function executed. We designed the extension so multiple vendors can bundle it and use it without interoperability issues.

See our download page for details on how to use it.

jQuery Includer

jQuery Includer

Free | Performance | Rovexo (formerly Elovaris Applications)
3
Score:
86
12 reviews
With this jQuery inclusion plugin you can: Include a minified, gzip compressed version of jQuery Set a far-future expire header for minimizing server requests. Include any older or more recent version of jQuery. The plugin makes sure jQuery is loaded before MooTools and noConflict is called immediately. Includes map files for all jQuery releases since 1.9.1 This release includes jQuery version 1.11.0 and the latest bugfix version of all previous releases. Access jQuery with "jQuery" in the global object scope instead of "$". If you like the plugin, please rate it and write a short review. Thanks! Please note that our extensions are only tested and supported on PHP 5.2.x and higher.
p

jRequire

Version:
1.0.0
Developer:
Rovexo (formerly Elovaris Applications)
Last updated:
May 27 2018
Date added:
May 15 2018
License:
GPLv2 or later
Type:
Free download
Includes:
Compatibility:
3 4 Alpha
Download

Uses Joomla! Update System

Demo Support Documentation
  • Overall
    Not rated
  • Functionality

    Not rated
  • Ease of use

    Not rated
  • Documentation

    Not rated
  • Support

    Not rated